The issue has been resolved, and we are now actively monitoring the situation.
Posted Mar 21, 2025 - 16:32 CET
Update
We appreciate your patience while our technical teams work to resolve the issue. We sincerely apologize for any inconvenience this may have caused and recognize that this is a busy time for your business.
Posted Mar 21, 2025 - 15:01 CET
Update
We are working as quick as possible to restore the service to normal levels. We appreciate your patience at this time.
Posted Mar 21, 2025 - 13:12 CET
Update
Our team continues to work on restoring the service. We apologize for any inconvenience caused and thank you for your patience.
Posted Mar 21, 2025 - 11:26 CET
Identified
The issue has been identified and a fix is being implemented. Sorry for the inconvenience.
Posted Mar 21, 2025 - 10:14 CET
Investigating
Currently, some users may experience problems trying to open assignment data Our teams are working to resolve the issue. We apologize for any inconvenience.